Subject: pkg/32998: devel/libgsf fails to link correctly (or something)
To: None <,,>
From: None <kre@munnari.OZ.AU>
List: pkgsrc-bugs
Date: 03/05/2006 06:55:00
>Number:         32998
>Category:       pkg
>Synopsis:       devel/libgsf fails to link correctly (or something)
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Mar 05 06:55:00 +0000 2006
>Originator:     Robert Elz
>Release:        NetBSD 3.99.15 (pkgsrc current as of 8 hours or so ago)
	Prince of Songkla University
System: NetBSD 3.99.15 NetBSD 3.99.15 (GENERIC-1.696-20060125) #8: Wed Jan 25 04:59:39 ICT 2006 i386
	Compiling pkgsrc using pkg_comp with libkver & NetBSD 3.0 release
Architecture: i386
Machine: i386
	dev/libgsf doesn't "make package", complaining about
	missing libtasn1 (this is after yesterday's update to
	both packages, libtasn1 is installed).

	pkg_comp build devel./libgsf

		cd ..../pkgsrc/devel/libgsf
		make package
	but I haven't tried that way - it wouldnb't make what I want)

	What I see is ...

===> [Automatic manual page handling]
===> Registering installation for libgsf-1.14.0
libgsf-1.14.0 requires installed package GConf2-2.12.1nb1
libgsf-1.14.0 requires installed package glib2-2.10.0
libgsf-1.14.0 requires installed package gnome-vfs2-2.12.2nb2
libgsf-1.14.0 requires installed package libbonobo-2.10.1nb2
libgsf-1.14.0 requires installed package libxml2-2.6.23nb1
/usr/pkg/lib/         -ltasn1.2 => not found
        -ltasn1.2 => not found
/usr/pkg/lib/     -ltasn1.2 => not found
        -ltasn1.2 => not found
/usr/pkg/lib/         -ltasn1.2 => not found
        -ltasn1.2 => not found
*** The above programs/libs will not find the listed shared libraries
    at runtime. Please fix the package (add -Wl,-R.../lib in the right places)!
*** Error code 1


The library is installed however ...
jade# pkg_comp pkg_info | grep ^lib
libtool-base-1.5.22nb2 Generic shared library support script (the script itself)
libIDL-0.8.6nb1     CORBA Interface Definition Language parser
libxml2-2.6.23nb1   XML parser library from the GNOME project
libcfg+-0.6.2nb3    Command line and configuration file parsing library
libgpg-error-1.0nb1 Definitions of common error values for all GnuPG components
libgcrypt-1.2.2nb1  GNU cryptographic library
libbonobo-2.10.1nb2 GNOME2 Object activation framework library
libtasn1-0.3.0      ASN.1 structure parser library
librfuncs-1.0.7nb1  Provides missing POSIX *_r functions
libpixman-0.1.6     Pixel manipulation library
libgsf-1.14.0       GNOME2 structured file library

	Notice that libgsf does get installed (the "make install" works)
	so when this is fixed a revision bump is required.

	I tried including ../../security/libtasn1/
	in libgsf's Makefile, but that made no difference.   That's
	probably because something is explicitly looking for
	whereas what's installed now is

	Oh, of course - a bunch of other libraries are still old ones,
	haven't been recompiled as no revbump was done on them.
	This is what I see using ldd on the libraries above (the
	ones that I currently have installed) - of course there
	might be many more than this that require a revbump now
	(the pkg_comp arena I'm using is new today, it doesn't have
	much installed ini t).

pkg_comp:default.conf# for f in *.so
echo $f
ldd $f | grep tasn
        -ltasn1.2 => not found
        -ltasn1.2 => not found
        -ltasn1.2 => not found
        -ltasn1.2 => not found
        -ltasn1.2 => not found
        -ltasn1.2 => not found
        -ltasn1.2 => not found
        -ltasn1.2 => not found

	An alternative might be to revert the libgsf change
	(so libgsf goes back to being 1.2) and put the new
	libgsf in a new package (libgsf3 perhaps) - if that's
	done, make it so that both libgsf variants can be
	installed together however.