Subject: Re: pkg/32331: pkgtools/libnbcompat broken on netbsd-2
To: None <>
From: grant beattie <>
List: pkgsrc-bugs
Date: 12/22/2005 21:30:17
On Sun, Dec 18, 2005 at 06:10:00PM +0000, Hauke Fath wrote:

> System: NetBSD q700 2.1_STABLE NetBSD 2.1_STABLE (FG54) #0: Sat Dec 17 21:58:39 CET 2005 hauke@q700:/usr/src/sys/arch/mac68k/compile/FG54 mac68k
> Architecture: m68k
> Machine: mac68k
> >Description:
> Building pkgtools/libnbcompat breaks on netbsd-2 (mac68k). I am marking
> this critical/high because it breaks pkg_install which breaks avery
> other build.

this is a local system problem, the netbsd-2 does not have statvfs.h,
so it should not be there.

is this a system which was downgraded from netbsd-3 or -current to
netbsd-2? currently, there is no way to automatically clean up stuff
which shouldn't be there when you downgrade.