Subject: pkg/32089: Bug in top level configure script for dspam 3.6.1
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 11/16/2005 10:24:00
>Number:         32089
>Category:       pkg
>Synopsis:       configure script in source for dspam 3.6.1 has -pthread instead of -lpthread
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Nov 16 10:24:00 +0000 2005
>Release:        NetBSD 1.6_STABLE
System: NetBSD slick 1.6_STABLE NetBSD 1.6_STABLE (_SLICK_) #0: Wed Sep 18 03:06:53 PDT 2002 root@slick:/usr/src/sys/arch/i386/compile/_SLICK_ i386
Architecture: i386
Machine: i386
The configure script created inside /usr/pkgsrc/mail/dspam/work/dspam-3.6.1/
has a repeated typo. Everywhere that reads -pthread *should* read -lpthread.
sup latest pkgsrc with 3.6.1 dspam
cd /usr/pkgsrc/mail/dspam && make
after unpacking source, manually edit /usr/pkgsrc/mail/work/dspam-3.6.1/configure and replace all instances of -pthread with -lpthread
./configure then works.