Subject: pkg/32053: www/opera needs emulators/suse91_openmotif
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 11/11/2005 23:33:00
>Number:         32053
>Category:       pkg
>Synopsis:       www/opera needs emulators/suse91_openmotif
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Nov 11 23:33:00 +0000 2005
>Originator:     Pawel Chwalowski
>Release:        2.1
NetBSD wodogrzmot. 2.1 NetBSD 2.1 (WODOGRZMOT) #3: Tue Nov  8 23:19:42 CET 2005  pawel@wodogrzmot.:/usr/src/sys/arch/i386/compile/WODOGRZMOT i386
bash-3.00$ pkg_info|grep opera
opera-8.50          Small, fast and customizable WWW client

It starts with an window with the error message:

Opera encountered a problem during plug-in setup.
Plug-ins will not work properly.
Check your insttallation.

Could not start plug-in executable 'operamotifwrapper'.
Please install Motif.

Plug-in path
(Path can be modified in Preferences dialog)

Start www/opera without emulators/suse91_openmotif installed.
--- www/opera/Makefile.ori	2005-11-12 00:18:38.000000000 +0100
+++ www/opera/Makefile	2005-11-12 00:19:55.000000000 +0100
@@ -38,6 +38,7 @@
 .if (${_OPERA_OPSYS} == NetBSD)
 DEPENDS+=	suse_x11>=7.3:../../emulators/${SUSE_DIR_PREFIX}_x11
+DEPENDS+=       suse_x11>=7.3:../../emulators/${SUSE_DIR_PREFIX}_openmotif
 # we need the DIST_SUBDIR=. because of the inclusion of suse's Makefile.common