Subject: Re: pkg/31533
To: None <,,>
From: Jeremy C. Reed <>
List: pkgsrc-bugs
Date: 10/11/2005 20:38:01
The following reply was made to PR pkg/31533; it has been noted by GNATS.

From: "Jeremy C. Reed" <>
To: Pavel Cahyna <>
Subject: Re: pkg/31533
Date: Tue, 11 Oct 2005 13:37:51 -0700 (PDT)

 On Tue, 11 Oct 2005, Pavel Cahyna wrote:
 > Thanks. BTW I don't have nautilus installed. Do you think that simply
 > installing it would fix the problem?
 Nautilus is needed for that.
 But that will not help yet. As xpdf is not registered as a known command.
 You need the update-desktop-database tool installed which comes from the 
 sysutils/desktop-file-utils package. nautilus uses 
 Then to make it so it works for galeon:
 1) Run natilus
 2) In the nautilus file browser fine some PDF file and right-click it.
 3) Choose "Properties"
 4) Click on the "Open With" tab.
 5) Select your PDF viewer (maybe evince is there?)
 5b) Or click on "Add" and add /usr/pkg/bin/xpdf.
 The above worked for me. Once I did that galeon added a "open" button when 
 I fetch a .pdf file. (This worked even after I closed nautilus.)
 I am carbon-copying the nautilus maintainer: Should nautilus also depend 
 on sysutils/desktop-file-utils package? If it is not installed nautilus 
 will complain about missing update-desktop-database command and won't 
 show added command handlers. (When I did install it, I ended up with three 
 "xpdf" choices -- so nautilus did remember, but just didn't show up until 
 I did it again.)
 As for galeon: should this depend on nautilus? Or should this just have a 
 MESSAGE. I think a MESSAGE would be good enough.
   Jeremy C. Reed
   	  	 	 BSD News, BSD tutorials, BSD links