Subject: pkg/30938: epiphany msg catalogs not compilable
To: None <,,>
From: Martin Husemann <>
List: pkgsrc-bugs
Date: 08/07/2005 22:37:01
>Number:         30938
>Category:       pkg
>Synopsis:       epiphany msg catalogs not compilable
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Aug 07 22:37:00 +0000 2005
>Originator:     Martin Husemann
>Release:        NetBSD 3.99.7
System: NetBSD 3.99.7 NetBSD 3.99.7 (NIGHT-OWL) #2: Fri Jul 8 23:33:45 CEST 2005 i386
Architecture: i386
Machine: i386

Compiling www/epiphany on NetBSD -current does not work. Apparently it's 
message catlogue *.gmo files are not compatible with the msgfmt in base:

file=`echo cs | sed 's,.*/,,'`.gmo  && rm -f $file && /usr/pkgobj/www/epiphany/work/.buildlink/bin/msgfmt -o $file cs.po
Fixing plural forms in cs.po
Running `/usr/bin/msgfmt -o cs.po.tmp'
cs.po.tmp:3942: duplicate message definition
cs.po.tmp:2145: ...this is the location of the first definition
/usr/bin/msgfmt: found 1 fatal error

Try to build it on NetBSD-current.

probably simple, if you knonw how to request a newer version of whatever
for the pkg.