Subject: pkg/30644: popt needs xgettext
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 07/01/2005 00:44:00
>Number:         30644
>Category:       pkg
>Synopsis:       popt needs gnu xgettext
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Fri Jul 01 00:44:00 +0000 2005
>Release:        NetBSD 1.6.2_STABLE
Building on SunOS 5.9 (configure says sparc-sun-solaris2.9) using
gcc version 3.3.4 (from package).

I do have /usr/pkg/bin/xgettext and I have a native xgettext (which is not
The popt configure runs 
  xgettext --version 2>&1 | grep 'GNU gettext'

I tried to override the text by setting XGETTEXT and ac_cv_path_XGETTEXT,
but I see it checks before allowing to be overridden.

Maybe xgettext should be added to work/.tools/bin/ or maybe the configure
script should be fixed.

My workaround was to temporarily modify the configure to run ${XGETTEXT}
instead of xgettext.

I noticed this in December. But haven't tested recently.
Attempt to build popt with a Solaris xgettext.
Use ${XGETTEXT} from gettext as a build dependency.