Subject: pkg/30558: can security/courier-authlib use the mysql-4.0.x tree?
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 06/19/2005 12:46:01
>Number:         30558
>Category:       pkg
>Synopsis:       can security/courier-authlib use the mysql-4.0.x tree?
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Sun Jun 19 12:46:01 +0000 2005
>Release:        NetBSD 1.6.2
System: NetBSD nixsys 1.6.2 NetBSD 1.6.2 (NIXSYS) #10: Thu Mar 4 22:20:38 EST 2004 root@nixsys:/usr/src/sys/arch/alpha/compile/NIXSYS alpha
Architecture: alpha
Machine: alpha

I believe at one time it was possible to build the courier authentication package using the mysql-4.0.x tree (for the authmysql service). Can we please have this back? I believe the old PKG_OPTIONS.courier-authlib (it was actually courier-auth back then) were mysql and mysql4. Modifying to include mysql-client's gives this on build:

===> Checking for vulnerabilities in courier-authlib-0.55
=> Checksum SHA1 OK for courier-authlib-0.55.tar.bz2.
=> Checksum RMD160 OK for courier-authlib-0.55.tar.bz2.
===> Extracting for courier-authlib-0.55
The supported build options for this package are:

	bdb ldap mysql pam pgsql

The currently selected options are:

	bdb mysql

You can select which build options to use by setting PKG_DEFAULT_OPTIONS
or the following variable.  Its current value is shown:

	PKG_OPTIONS.courier-authlib = mysql

Deprecated variable USE_OPENLDAP used, use PKG_DEFAULT_OPTIONS+=ldap instead.
Deprecated option PAM used, use option pam instead.

The following variables will affect the build process of this package,
courier-authlib-0.55.  Their current value is shown below:

        * BDBBASE (defined)
        * BDB_TYPE = db1
        * SSLBASE (defined)

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/bin/make clean' after
the changes.
===> Required installed package {perl>=5.0,perl-thread>=5.0}: perl-5.8.6nb3 found
===> Required installed package mysql-client>=4.0.24: mysql-client-4.0.24 found
===> Required installed package openssl>=0.9.7d: openssl-0.9.7e found
===> Required installed package zlib>=1.2.1nb3: zlib-1.2.2 found
===> Required installed package libltdl>=1.5.10: libltdl-1.5.18 found
===> Required installed package libtool-base>=1.5.18nb1: libtool-base-1.5.18nb3 found
===> Required installed package gmake>=3.78: gmake-3.80nb4 found
===> Patching for courier-authlib-0.55
===> Applying pkgsrc patches for courier-authlib-0.55
===> Overriding tools for courier-authlib-0.55
pkg_info: missing package name(s)
usage: pkg_info [-BbcDdFfhIikLmNnpqRrSsVv] [-e package] [-K pkg_dbdir] [-l prefix]
                pkg-name [pkg-name ...]
       pkg_info -a [flags]
       pkg_info -Q variable pkg-name [pkg-name ...]
make: "/usr/src/sys/pkgsrc/security/courier-authlib/../../mk/wrapper/../../mk/buildlink3/" line 48: warning: Couldn't read shell's output for "/usr/sbin/pkg_info -K . -qp  | /usr/bin/sed  -e "s,^[^/]*,,;q""
===> Creating toolchain wrappers for courier-authlib-0.55
Syntax error: expecting "in"
*** Error code 2

make: stopped in /usr/src/sys/pkgsrc/security/courier-authlib
*** Error code 1

make: stopped in /sys/pkgsrc/security/courier-authlib

	make security/courier-authlib with including mysql-client's