Subject: pkg/30547: please bump ap2-perl to 2.0.0 and p5-libapreq2 to libapreq2-2.05-dev
To: None <,,>
From: Carl Brewer <>
List: pkgsrc-bugs
Date: 06/18/2005 03:53:00
>Number:         30547
>Category:       pkg
>Synopsis:       please bump ap2-perl to 2.0.0 and p5-libapreq2 to libapreq2-2.05-dev
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Sat Jun 18 03:53:00 +0000 2005
>Originator:     Carl Brewer
>Release:        NetBSD 1.6.2
System: NetBSD 1.6.2 NetBSD 1.6.2 (rollcage) #1: Fri Apr 23 00:50:50 EST 2004 i386
Architecture: i386
Machine: i386
	apache modperl2.0.0 was released some time ago with an
api change (apache:: is replaced by apache2::).  This will 
clash with some installed pkgs, in particular libapreq and p5-CGI - 
PR 30302 is for p5-CGI upgrade to 3.10 (which deals with the API

	Is there any chance that whoever looks after this pkg could
make the relevant changes?  I've been using modperl2.0.0 on
a couple of NBSD (1.6.2, 2.0.2, 2.0.0) i386 boxes for some weeks
now with no detected problems after a compile from source.  It would
be nice to have it in pkgsrc now!

	ap2-perl makefile change - must include a "remove earlier
versions" dependancy - modperl2.0 checks for earlier API versions (1.99.17
etc) and will refuse to build if modperl2 versions prior to 1.999022
are detected by it.  I don't know how to do this within pkgsrc.

Other pkgs will be affected by this - See

Pkgs I think will be affected are :

p5-libapreq2 - this will need bumping to the current release - it's
presently libapreq2-2.04_03-dev and it needs to be 

Not sure if it's ok to combine these in one PR?