Subject: pkg/30527: Inconsistent .includes in x11/py-gnome Makefile and
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 06/14/2005 23:43:00
>Number:         30527
>Category:       pkg
>Synopsis:       Inconsistent .includes in x11/py-gnome Makefile and
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Jun 14 23:43:00 +0000 2005
>Originator:     Krister Walfridsson
>Release:        pkgsrc as of Jun 13 2005
System: NetBSD 1.6.2_STABLE NetBSD 1.6.2_STABLE (tmp) #0: Thu Apr 15 06:12:56 UTC 2004 i386
Architecture: i386
Machine: i386
The x11/py-gnome2/ includes some buildlink files
(e.g. ../../x11/gnome-panel/ that are not included
in x11/py-gnome2/Makefile.

This has the result that bulk builds end up with an inconsistent
dependency graph, and binary packages with missing dependencies
may be created.

This problem was introduced in the last update of x11/py-gnome,
where the dependencies were moved to py-gnome2-extras.