Subject: pkg/30468: ...pkgsrc/sysutils/gnome-vfs2 cannot build.
To: None <,,>
From: Richard Rauch <>
List: pkgsrc-bugs
Date: 06/08/2005 20:07:00
>Number:         30468
>Category:       pkg
>Synopsis:       ...pkgsrc/sysutils/gnome-vfs2 cannot build.
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jun 08 20:07:00 +0000 2005
>Originator:     Richard Rauch
>Release:        NetBSD 3.99.3
  "I probably don't know what I'm talking about."
System: NetBSD socrates 3.99.3 NetBSD 3.99.3 (socrates) #0: Fri Apr 8 16:13:11 CDT 2005 root@socrates:/usr/kernobj/usr/netbsd/current/src/sys/arch/amd64/compile/socrates amd64
Architecture: x86_64
Machine: amd64
	After a recent pkgsrc update (owing to security issues),
	GIMP was deinstalled.  Trying to rebuild and reinstall it
	fails.  The error that I get is:

===> Overriding tools for gnome-vfs2-2.10.1
pkg_info: missing package name(s)
usage: pkg_info [-BbcDdFfhIikLmNnpqRrSsVv] [-e package] [-K pkg_dbdir] [-l prefix]
                pkg-name [pkg-name ...]
       pkg_info -a [flags]
       pkg_info -Q variable pkg-name [pkg-name ...]
make: "../../mk/wrapper/../../mk/buildlink3/../../mk/wrapper/../../mk/buildlink3/" line 325: warning: Couldn't read shell's output for "/usr/sbin/pkg_info -K . -qp  | /usr/bin/sed  -e "s,^[^/]*,,;q""
===> Creating toolchain wrappers for gnome-vfs2-2.10.1
Syntax error: expecting "in"
*** Error code 2

	Jeremy C. Reed confirms that he saw the same problem with ggv; see 
	for his tech-pkg report.

	I'm not sure how many packages this breaks, though it seems
	that some packages still build.

	Jeremy posted a workaround for the ggv package, but I'm not sure
	that it is a general workaround, so I am leaving this in the
	"critical" category.

	Effectively, this breaks the GIMP for me, since the GIMP indirectly
	requires gnome-vfs2.

	On my system, try to build gnome-vfs2.  Or on Jeremy's, try to
	rebuild ggv (he just confirmed that the problem is still outstanding
	for him).

	Jeremy's post to tech-package at
	contains a workaround for his problem.  I haven't tried it,
	since it's not clear which of his steps are really part of the
	workaround (he lists several things that he tried, but doesn't
	say if he undid anything)

	He implies that rebuilding glibc may also fix the problem, but
	I'm loathe to try that as I am not sure how many packages I'd lose
	if I tried to do that and found *more* packages no longer build.