Subject: pkg/30454: vpnc installs helper scripts that don't run on NetBSD
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 06/07/2005 09:25:00
>Number:         30454
>Category:       pkg
>Synopsis:       vpnc installs helper scripts that don't run on NetBSD
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Tue Jun 07 09:25:00 +0000 2005
>Originator:     Ignatios Souvatzis
>Release:        NetBSD 2.0.2_STABLE
System: NetBSD laptop 2.0.2_STABLE NetBSD 2.0.2_STABLE (GENERIC_LAPTOP) #14: Wed Jun 1 08:38:25 CEST 2005 ignatios@laptop:/usr/local/sources/20/oi/sys/arch/i386/compile/GENERIC_LAPTOP i386
Architecture: i386
Machine: i386
Information for vpnc-0.3.2:

Client for Cisco3000 VPN Concentrator


vpnc is a VPN client for the Cisco 3000 VPN Concentrator, creating
an IPSec-like connection as a tunneling network device for the
local system.


	The vpnc package contains helper scripts that can be invoked
	by the vpnc daemon after connection establishment to set up
	the default route. However, those are Linux scripts and won't
	work on other operating systems.
	Replacement scripts for NetBSD should be added to the package,
	and installed. Maybe scripts for various operating systems 
	should be installed in the examples directory instead of the
	executable directory.