Subject: pkg/30441: "pkg_chk -i -f" doesn't work anymore
To: None <,,>
From: Matthias Scheler <>
List: pkgsrc-bugs
Date: 06/06/2005 09:08:00
>Number:         30441
>Category:       pkg
>Synopsis:       "pkg_chk -i -f" doesn't work anymore
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Jun 06 09:08:00 +0000 2005
>Release:        NetBSD 3.0_BETA 2005-06-06 sources,
Matthias Scheler                        
System: NetBSD 3.0_BETA NetBSD 3.0_BETA (COLWYN) #0: Sun May 29 12:34:37 BST 2005 i386
Architecture: i386
Machine: i386

Information for pkg_chk-1.59:

Check installed package versions against pkgsrc

pkg_chk verifies that the versions of installed packages matches those in
pkgsrc, optionally adding missing or updating mismatched packages.

It can verify all installed packages, or check against a set of packages
based on the hostname, architecture, and other characteristics.


"pkg_chk" will now longer fetch distfiles for packages which need to
be updated:

tron@colwyn:/usr/pkgsrc/net/samba>pkg_chk -i -f
samba-3.0.14anb1: version mismatch - samba-3.0.10nb2
[ Fetch ]
tron@colwyn:/usr/pkgsrc/net/samba>make fetch
===> Checking for vulnerabilities in samba-3.0.14anb1
=> samba-3.0.14a.tar.gz doesn't seem to exist on this system.
=> Attempting to fetch samba-3.0.14a.tar.gz from
=> [15605851 bytes]

Use "pkg_chk -i -f" on a system with at least one outdated package.

None provided.