Subject: Re: pkg/30317
To: None <,,>
From: Matthias Drochner <>
List: pkgsrc-bugs
Date: 05/25/2005 20:02:01
The following reply was made to PR pkg/30317; it has been noted by GNATS.

From: Matthias Drochner <>
Subject: Re: pkg/30317 
Date: Wed, 25 May 2005 22:01:19 +0200 said:
 >  Apart from the following line, the package works on NetBSD 1.6.2 when
 > I 
 >  remove the "native" flag from PTHREAD_OPTS. 
 OK, it might be easyer than I thought to get a pkg for 1.6.
 Can you try something like the following:
 PTHREAD_OPTS+= native
 .include "../../mk/"
 .if defined(PTHREAD_TYPE) && ${PTHREAD_TYPE} == "native"
 PLIST_SUBST+= HAVE_THR="@comment "
 and put a "${HAVE_THR}" in front of the pthread.dll PLIST entry.
 best regards