Subject: pkg/30338: acroread7 package doesn't work right on x86
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 05/25/2005 19:28:00
>Number:         30338
>Category:       pkg
>Synopsis:       acroread7 package doesn't work right on x86
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed May 25 19:28:00 +0000 2005
>Originator:     Perry E. Metzger
>Release:        NetBSD 3.99.5
Perry E. Metzger
"Ask not what your country can force other people to do for you..."
System: NetBSD hackworth 3.99.5 NetBSD 3.99.5 (HACKWORTH) #0: Tue May 24 13:32:09 EDT 2005 perry@hackworth:/usr/src/sys/arch/i386/compile/HACKWORTH i386
Architecture: i386
Machine: i386
	acroread7 installs just fine. Unfortunately, when it tries to
	a pdf, I get the following spew just before it crashes:

(acroread:10447): GdkPixbuf-WARNING **: Error loading XPM image loader: Image type 'xpm' is not supported

	Note that I'm using the suse9 linux compat stuff.

	I'm not sure why it dies, but I suspect some linux compat
	library or executable is missing.
	cd /usr/pkgsrc/print/acroread7
	make install
	cd somewhere
	acroread foo.pdf