Subject: pkg/29962: php-imap fails to build
To: None <,,>
From: Kimmo Suominen <>
List: pkgsrc-bugs
Date: 04/13/2005 12:54:00
>Number:         29962
>Category:       pkg
>Synopsis:       php-imap fails to build
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Apr 13 12:54:00 +0000 2005
>Originator:     Kimmo Suominen
>Release:        NetBSD 3.99.3 / pkgsrc 2005-04-13
Kimmo Suominen
System: NetBSD 3.99.3 NetBSD 3.99.3 (GW-GENERIC) #109: Mon Apr 11 12:23:52 EDT 2005 i386
Architecture: i386
Machine: i386

I cannot build php-imap (with php-4.3.11 and imap-uw-2004c1nb2).  The
configure script fails to find OpenSSL (from base):

    configure: error: Cannot find OpenSSL's <evp.h>

Setting SSLBASE explicitly to /usr does not help.  The include file
/usr/include/openssl/evp.h does exist, as does /usr/lib/
(also required by the configure script).

Run "make" in pkgsrc/mail/php-imap.