Subject: pkg/29908: docbook-* pkgs missing xmlcatmgr dependency
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 04/06/2005 19:00:00
>Number:         29908
>Category:       pkg
>Synopsis:       docbook-* pkgs missing xmlcatmgr dependency
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Apr 06 19:00:00 +0000 2005
>Originator:     Juan RP
>Release:        NetBSD 3.99.3
System: NetBSD XenUN 3.99.3 NetBSD 3.99.3 (XenU) #1: Wed Apr 6 18:20:19 CEST 2005 juan@Nocturno:/home/juan/build/obj/sys/arch/i386/compile/XenU i386
	cd pkgsrc/textproc/docbook-xml && make install:

[juan@Nocturno][/usr/pkgsrc/textproc/docbook-xml]> make install
===> Checking for vulnerabilities in docbook-xml-4.2nb8
=> Checksum SHA1 OK for
=> Checksum RMD160 OK for
===> Extracting for docbook-xml-4.2nb8
===> Required installed package ccache-[0-9]*: ccache-2.4 found
===> Required installed package unzip-[0-9]*: unzip-5.52nb1 found
===> Patching for docbook-xml-4.2nb8
===> Applying pkgsrc patches for docbook-xml-4.2nb8
===> Overriding tools for docbook-xml-4.2nb8
===> Configuring for docbook-xml-4.2nb8
===> Installing for docbook-xml-4.2nb8
===> Becoming root@Nocturno to install docbook-xml.
/usr/pkg/bin/sudo install -d -o root -g wheel -m 755 /usr/pkg/share/xml/docbook
install -d -o root -g wheel -m 755 /usr/pkg/share/xml/docbook/ent
(cd /usr/pkgsrc/textproc/docbook-xml/work; install -c -o root -g wheel -m 444 calstblx.dtd dbcentx.mod dbgenent.mod dbhierx.mod  dbnotnx.mod dbpoolx.mod docbookx.dtd soextblx.dtd /usr/pkg/share/xml/docbook)
(cd /usr/pkgsrc/textproc/docbook-xml/work/ent; install -c -o root -g wheel -m 444 *.ent /usr/pkg/share/xml/docbook/ent)
(cd /usr/pkgsrc/textproc/docbook-xml/work;     install -c -o root -g wheel -m 444 README /usr/pkg/share/xml/docbook)
install -c -o root -g wheel -m 444 /usr/pkgsrc/textproc/docbook-xml/work/catalog.xml /usr/pkg/share/xml/docbook/catalog
/usr/pkgsrc/textproc/docbook-xml/work/.pkgdb/+INSTALL: /usr/pkg/bin/xmlcatmgr: not found
===> Registering installation for docbook-xml-4.2nb8

	The package was installed, but the catalogs were not
	installed correctly.

	All packages using XML catalogs are affected.
	Yes, please!