Subject: Re: pkg/29818
To: None <,,>
From: James K. Lowden <>
List: pkgsrc-bugs
Date: 04/05/2005 05:36:02
The following reply was made to PR pkg/29818; it has been noted by GNATS.

From: "James K. Lowden" <>
Subject: Re: pkg/29818
Date: Tue, 5 Apr 2005 01:34:59 -0400

 On Mon, 28 Mar 2005 19:09:11 +0000 (UTC), wrote:
 > Synopsis: gnome2-control-center fails relink at "make install"
 > Anyway, to make sure
 > everything is correct, can you do the following?
 > make show-var VARNAME=USE_LIBTOOL
 pushd ../../x11/gnome2-control-center
 /usr/pkgsrc/x11/gnome2-control-center /usr/pkgsrc/meta-pkgs/gnome 
 $ make show-var VARNAME=USE_LIBTOOL
 > Also, is your pkgsrc tree (specially the mk directory) up to date?
 Updated March 27: 
 $ for F in $(cvs status | grep ^File |grep -v Up-to-date | awk '{print
 $2}' ); do find . -name $F; done | xargs echo cvs status | sh -x + cvs
 status ./bulk/ ./install/usergroup ./platform/
 File:   Status: Needs Patch
    Working revision:    1.77
    Repository revision: 1.78    /cvsroot/pkgsrc/mk/bulk/,v
    Sticky Tag:          (none)
    Sticky Date:         (none)
    Sticky Options:      (none)
 File: usergroup         Status: Needs Patch
    Working revision:    1.7
    Repository revision: 1.8     /cvsroot/pkgsrc/mk/install/usergroup,v
    Sticky Tag:          (none)
    Sticky Date:         (none)
    Sticky Options:      (none)
 File:        Status: Needs Patch
    Working revision:    1.29
    Repository revision: 1.30    /cvsroot/pkgsrc/mk/platform/,v
    Sticky Tag:          (none)
    Sticky Date:         (none)
    Sticky Options:      (none)
 > How old is your libtool-base installed package?
 $ which libtool
 $ libtool --version |grep GNU (GNU libtool) 1.5.14 (1.1220.2.195 2005/02/12 12:12:33)
 > Have you tried cleaning gnome2-control-center and rebuilding it again?
 > Do this directly from the package's directory, not from the meta-pkg.
 Actually, I hadn't tried that, so I did.  "make" went fine.  "make
 install" complained about the already-installed 2.8 version.  I
 deinstalled it (had to pkg_delete gnome-base and gnome-session) and tried
 "make install" again.  Only *then* did it choke: at the same point [1].  
 (Is this part of the brave new world of buildlink3?  I got used to the
 idea that by the time we said "make install", all the compiling and
 linking was done, and all that remained was to move the files into
 $LOCALBASE and update the database.)
 Thanks for taking the time to work on this, Julio.  Whatever else you
 need, just let me know.  I can putz with this for you a bit: I'm replacing
 my workstation, which is currently running Gnome 1.  I don't lose any
 functionality while I'm building the new one.  
 [1] cc -shared  .libs/themus-properties-view.o
 .libs/themus-properties-main.o -Wl,--
 whole-archive ../../capplets/common/.libs/libcommon.a
 -Wl,--no-whole-archive  -W
 l,--rpath -Wl,/usr/pkg/tmp/x11/gnome2-control-center/work/.buildlink/lib
 path -Wl,/usr/pkg/lib
 nk/lib -L/usr/pkg/tmp/x11/gnome2-control-center/work/.buildlink/lib
 r-2.10.0/capplets/common/.libs -L/usr/pkg/lib -lgnome-window-settings
 0 -lgnome-menu -lmetacity-private -lXrandr -lXext -lXinerama -lXrender
 esktop-2 -lgnomeui-2 -lgnome-keyring -ljpeg -lstartup-notification-1
 2 -lSM -lICE -lX11 -lgnomecanvas-2 -lgnome-2 -lesd -lossaudio -laudiofile
 lgpl_2 -lpangoft2-1.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0
 -lgdk_pixbuf-2.0 -lp
 angoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgnomevfs-2 -lxml2 -lgnutls -ltasn1
 pt -lgpg-error -lz -lrt -lbonobo-2 -lgconf-2 -lbonobo-activation
 g-2 -lORBit-2 -lpopt -lgobject-2.0 -lm -lgmodule-2.0 -lgthread-2.0
 -lglib-2.0 -l
 intl  -Wl,-R/usr/X11R6/lib -Wl,-R/usr/pkg/lib -pthread -Wl,-soname
 -Wl,libnautil -Wl,-retain-symbols-file -Wl,.libs/libnautilus-themus.exp -o
 ld: cannot find -lgnome-window-settings
 libtool: install: error: relink `' with the above
 command b
 efore installing it
 gmake[3]: *** [install-nautilusLTLIBRARIES] Error 1
 gmake[3]: Leaving directory