Subject: pkg/29802: bibtex2html fails to build with latest ocaml
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 03/27/2005 20:14:00
>Number:         29802
>Category:       pkg
>Synopsis:       bibtex2html fails to build with latest ocaml. linking failure
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Sun Mar 27 20:14:00 +0000 2005
>Originator:     Antoine Reilles
>Release:        NetBSD 3.99.1
System: NetBSD 3.99.1 NetBSD 3.99.1 (GENERIC) #0: Wed Mar 23 15:17:57 CET 2005 i386
Architecture: i386
Machine: i386
bibtex2html fails to build. There is a linking failure, with -lstr been not found by ld.
Of course, it cannot be found, since bibtex2html does not use the buildlink3 from ocaml
update ocaml to 3.08.3, then try to make bibtex2html-1.75
just adding a line
.include "../../lang/ocaml/"
.include "../../mk/"
in Makefile fixes the issue. str is now found by ld.