Subject: pkg/29777: Error building courier-authlib with option mysql
To: None <,,>
From: Charlie Root <>
List: pkgsrc-bugs
Date: 03/23/2005 18:58:00
	Note: There was a bad value `' for the field `Class'.
	It was set to the default value of `sw-bug'.

>Number:         29777
>Category:       pkg
>Synopsis:       Build stops because: ld: unrecognized option '-Wl'
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Mar 23 18:58:00 +0000 2005
>Originator:     Serban Udrea
>Release:        NetBSD 2.0
System: NetBSD 2.0 NetBSD 2.0 (GENERIC) #0: Wed Dec 1 10:58:25 UTC 2004 builds@build:/big/builds/ab/netbsd-2-0-RELEASE/i386/200411300000Z-obj/big/builds/ab/netbsd-2-0-RELEASE/src/sys/arch/i386/compile/GENERIC i386
Architecture: i386
Machine: i386
The build of courier-authlib stops because of the following error:
		ld: unrecognized option '-Wl'
	      This happens immediately after the message:
	      From .work.log results that options of the form -Wl,-Wl are passed to gcc
	      thus -Wl is passed to the linker.
Put PKG_OPTIONS.courier-authlib= bdb mysql in /etc/mk.conf and do make in
I have no fix, sorry :-(