Subject: Re: pkg/23425
To: None <>
From: Andrew Brown <>
List: pkgsrc-bugs
Date: 03/18/2005 00:02:05
On Thu, Mar 17, 2005 at 05:07:48PM +0000, wrote:
>Synopsis: Can we track OS version in lsof and aperture like we do in p5-perl-headers?
>Responsible-Changed-From-To: pkg-manager->atatat
>Responsible-Changed-When: Thu, 17 Mar 2005 17:07:47 +0000
>Over to lsof maintainer.
>(for handling the lsof part of the PR)

i think lsof is already okay on this front.

(1) it already prints out a warning saying that it might not work and
then tries anyway.  case in point, my 2.99.14 lsof works fine on
2.99.16.  i'll try it on 3.99.1 tomorrow.  :)

(2) if we make it refuse to work if the kernel version is different,
we eliminate a great many cases where it might work anyway.

fwiw, i have two lkms that i built 1.5 years that i force-load and
they still work fine.

|-----< "CODE WARRIOR" >-----|             * "ah!  i see you have the internet (Andrew Brown)                that goes *ping*!"       * "information is power -- share the wealth."