Subject: pkg/29620: www/navigator-4.80 not compatable with ns-flash>=7.0
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 03/07/2005 22:49:01
>Number:         29620
>Category:       pkg
>Synopsis:       the ns-flash 7.x plugin is no longer compatable with navigator 4.80
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Mar 07 22:49:00 +0000 2005
>Originator:     Christoph Badura
>Release:        NetBSD 2.0_STABLE pkgsrc-current as of 2005-03-07
System: NetBSD limiting-factor 2.0_STABLE NetBSD 2.0_STABLE (GENERIC_LAPTOP) #0: Mon Mar 7 20:38:26 MET 2005 bad@limiting-factor:/u/1/obj/u/1/src/sys/arch/i386/compile/GENERIC_LAPTOP i386
Architecture: i386
Machine: i386
installing www/navigator pulls in multimedia/ns-flash too.
Version 7.x of the ns-flash plugin is no longer compatable with the
navigator 4.80 binary for Linux.  When the flash plugin is installed
navigator complains on startup with:
	ERROR: /usr/pkg/lib/netscape/plugins/flashplayer.xpt: invalid ELF header
	Cant load plugin /usr/pkg/lib/netscape/plugins/flashplayer.xpt. Ignored.
and dumps core.

The same is probably true for the communicator binary.

	cd pkgsrc/www/navigator && make install
Don't automatically install the ns-flash package when installing navigator/
communicator.  And make ns-flash>7 conflict with navigator/communicator <= 4.80.
Maybe bring back an older version of the plugin.