Subject: pkg/29587: evolution needs newer pkg versions than dependencies state
To: None <,,>
From: Mark Davies <>
List: pkgsrc-bugs
Date: 03/03/2005 21:18:00
>Number:         29587
>Category:       pkg
>Synopsis:       evolution needs newer pkg versions than dependencies state
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Mar 03 21:18:00 +0000 2005
>Originator:     Mark Davies
>Release:        NetBSD 2.99.10
Dept. of Comp. Sci., Victoria Uni. of Wellington, New Zealand.
System: NetBSD 2.99.10 NetBSD 2.99.10 (MCS_WORKSTATION) #7: Tue Feb 1 23:23:04 NZDT 2005 i386
Architecture: i386
Machine: i386
	evolution 2.0.4 requires evolution-data-server 2.0.4 and gtkhtml3 3.2.5
	but package dependencies allow older versions
	try to build evolution-2.0.4 when you have evolution-data-server-2.0.3
	and gtkhtml3-3.2.4 installed.  Note that dependencies are satisfied
	but build dies with:

checking for libegroupwise-1.0 >= 1.0.4... Requested 'libegroupwise-1.0 >= 1.0.4' but version of libegroupwise is 1.0.3

configure: error: Library requirements (libegroupwise-1.0 >= 1.0.4) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
*** Error code 1

	and if you update evolution-data-server, evolution build then dies
	with a similar complaint about gtkhtml3.
	Bump the required versions in the evolution Makefile