Subject: pkg/29575: editors/xemacs PLIST issue
To: None <,,>
From: Hauke Fath <>
List: pkgsrc-bugs
Date: 03/02/2005 12:51:00
>Number:         29575
>Category:       pkg
>Synopsis:       editors/xemacs PLIST issue
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Mar 02 12:51:00 +0000 2005
>Originator:     Hauke Fath <>
>Release:        Solaris 9 with current pkgsrc
/~\  The ASCII Ribbon Campaign                    Hauke Fath
\ /    No HTML/RTF in email	        Institut für Nachrichtentechnik
 X     No Word docs in email	                  TU Darmstadt
/ \  Respect for open standards              Ruf +49-6151-16-3281
SunOS sunchen 5.9 Generic_112233-12 sun4u sparc SUNW,Ultra-1

When installing editors/xemacs without mule, 'make install' complains
about a PLIST mismatch:

$NetBSD: MESSAGE,v 1.4 2003/02/26 00:33:48 uebayasi Exp $

* See /usr/pkg/lib/xemacs-21.4.17/etc/sample.init.el for a sample user
  configuration.  Copying it to ~/.xemacs/init.el is an easy start.

* See /usr/pkg/lib/xemacs-21.4.17/etc/sample.Xdefaults for a sample X
  resource setting.

* Install `xemacs-packages' for a full set of support packages.


/usr/pkg/lib/xemacs-21.4.17/lisp/mule/canna-leim.elc: No such file or directory
===> Registering installation for xemacs-21.4.17
pkg_create: can't stat `/usr/pkg/lib/xemacs-21.4.17/lisp/mule/canna-leim.elc'
xemacs-21.4.17 requires installed package gdbm-1.8.3nb1
xemacs-21.4.17 requires installed package jpeg-6bnb3
xemacs-21.4.17 requires installed package png-1.2.8
xemacs-21.4.17 requires installed package tiff-3.7.1nb3
[hf@sunchen] /<2>editors/xemacs # fgrep -i emacs /etc/mk
mk.conf  mkfs@    mknod@   
[hf@sunchen] /<2>editors/xemacs # fgrep -i emacs /etc/mk.conf 
PKG_OPTIONS.xemacs =    # empty
[hf@sunchen] /<2>editors/xemacs #


	Set an empty PKG_OPTIONS.xemacs, install editors/xemacs - this
	is Solaris, but should be OS independent.