Subject: pkg/29561: suse73 -> sus91 update glitches
To: None <,,>
From: None <kre@munnari.OZ.AU>
List: pkgsrc-bugs
Date: 03/01/2005 03:40:01
>Number:         29561
>Category:       pkg
>Synopsis:       suse73 -> sus91 update glitches
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Mar 01 03:40:01 +0000 2005
>Originator:     Robert Elz
>Release:        NetBSD 2.0.1   (-- pkgsrc current as of 4/5 hours before e-mail)
	Prince of Songkla University
System: NetBSD 2.0.1 NetBSD 2.0.1 (JADE-1.7-20050129) #1: Sat Jan 29 15:40:38 ICT 2005 i386
Architecture: i386
Machine: i386
	There are a bunch of packages that depend upon suse packages that
	exist in the suse73 set, but don't exist in the suse91 set.

	Those are
		emulators/vmware		wants suse91_vmware
		emulators/vmware3		wants suse91_vmware
		games/quake3arena		wants suse91_glx
		games/quake3arena-demo		wants suse91_glx
		multimedia/trplayer		wants suse91_libc5 suse91_slang
		www/asWedit			wants suse91_libc5

	The packages lilsted after "wants" don't exist in the suse91 form
	(not in NetBSD pkgsrc anyway), the suse73 variants do exist.

	Attempt to make any of the packages listed above on a NetBSD 2 (or
	-current) system, without the suse73 package set already installed.
	(Not sure if the "without" is a requirement or not).

	Either find the suse91 packages required, and import them, or
	make a method to allow those packages to explicitly depend upon the
	suse73 linux emulations, and change them to use that method (providing
	there are no problems having both 73 & 91 installed, which there
	shouldn't be really)..