Subject: Re: pkg/25274
To: None <>
From: Robert Elz <kre@munnari.OZ.AU>
List: pkgsrc-bugs
Date: 12/28/2004 13:50:58
    Date:        Mon, 27 Dec 2004 22:06:55 +0000 (UTC)
    Message-ID:  <>

  | Synopsis: blt (current) doesn't build w/ tcl 8.4.6
  | State-Changed-From-To: open->feedback
  | State-Changed-By:
  | State-Changed-When: Mon, 27 Dec 2004 22:06:54 +0000
  | State-Changed-Why:
  | Built fine in the latest 2.0 bulk build -- do you still see a problem?

That's not my PR (so this message probably doesn't count as feedback),
but I have seen a lot of packages that behave just as described in the
past few days (using a pkgsrc that was current as of no more than a day
before anoncvs went away - so if changes have been made in the past couple
of days, ignore this message!)

The problem is that blt (and lots of other stuff) does ...

	.include "../../lang/tcl83/"
	.include "../../x11/tk83/"

which demands TCL (& TK) 8.3.*.    That's fine if no tcl/tk is installed,
or if the version installed is 8.3.*.   But, if tcl 8.4 is installed
instead, then we get a CONFLICTS because tcl-8.3.* can't be installed
when there's a tcl-8.4.* already there (whether or not there's an actual
conflict in this case, or whether it is just because the mk/* files
assume that two packages with the same base name and different versions
always conflict I haven't bothered to find out).

That bulk builds work just means that some package the bulk build is
building installed tcl 8.3 before anything gets a chance to install 8.4.
(That or each package starts in a clean environment, which would have the
same effect - never done a bulk build personally).

I'm not sure how many packages that I have come across in the past week
suffer from this - certainly not all of the tcl/tk packages do, some don't
seem to mind which version of tcl is there, but there are more than just
a few that are explicitly demanding 8.3.* (for good reason, or just because
8.3 was the version that was current when they were imported I have no idea).