Subject: Re: pkg/28695: keyring plugin fails for comms/jpilot
To: Johnny C. Lam <>
From: Michael van Elst <>
List: pkgsrc-bugs
Date: 12/18/2004 21:02:57
On Sat, Dec 18, 2004 at 12:05:40PM -0500, Johnny C. Lam wrote:
> Michael van Elst wrote:
> >On Sat, Dec 18, 2004 at 12:20:54AM +0000, Johnny C. Lam wrote:
> >
> >
> >>Could you supply the .work.log from a build of this package?  That
> >>will contain enough information to fix this problem.
> >
> >
> >I sent the log with a separate mail. I don't know if gnats can
> >handle attachments correctly.
> I see in the work log that -lcrypto isn't being converted into "-ldes 
> -lcrypto" by the wrapper scripts.  Can you check that you have revision 
> 1.8 of pkgsrc/security/openssl/

I used 1.6, but upgrading to 1.8 doesn't change anything.
As far as I can see the file isn't included.

If I add

.include "../../security/openssl/"

to jpilot's Makefile, then it is linked correctly.

                                Michael van Elst
                                "A potential Snark may lurk in every tree."