Subject: pkg/28572: sysutils/xfce4-minicmd-plugin fails to build
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 12/07/2004 15:36:01
>Number:         28572
>Category:       pkg
>Synopsis:       sysutils/xfce4-minicmd-plugin fails to build
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Dec 07 15:36:00 +0000 2004
>Originator:     david howland
>Release:        2.0
NetBSD micron 2.0 NetBSD 2.0 (ROUTER) #0: Tue Nov 30 10:20:58 EST 2004  dave@micron:/usr/obj/sys/arch/i386/compile/ROUTER i386
sysutils/xfce4-minicmd-plugin was upgraded from 0.2 to 0.3 and now fails to build.

Stops at the configure stage, with the following error:
checking whether stripping libraries is possible... yes
checking for ANSI C header files... (cached) yes
checking for xfce4-panel-1.0 >= 4.1.90... Requested 'xfce4-panel-1.0 >= 4.1.90' but version of xfce4-panel is 4.0.6

configure: error: Library requirements (xfce4-panel-1.0 >= 4.1.90) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
*** Error code 1

make: stopped in /usr/pkgsrc/sysutils/xfce4-minicmd-plugin
*** Error code 1

make: stopped in /usr/pkgsrc/sysutils/xfce4-minicmd-plugin

minicmd seems to have been updated to the new version which expects the new version of xfce, 4.2 (4.1.90), to be installed.  pkgsrc currently has the old version, 4.0.6.  Xfce 4.2 is at the RC stage.  This is probably also a problem with other Xfce plugins.  I don't know if minicmd 0.3 will work with Xfce 4.0.6 if it could compile.

cd /usr/pkgsrc/sysutils/xfce4-minicmd-plugin && make

Roll back the minicmd plugin to 0.2 or upgrade xfce to >4.1.90 (4.2)
Probably the former, if pkgsrc is frozen.