Subject: pkg/26801: pkgsrc/comms/mgetty+sendfax assumes presence of libutil
To: None <>
From: None <>
List: pkgsrc-bugs
Date: 08/29/2004 20:39:08
>Number:         26801
>Category:       pkg
>Synopsis:       pkgsrc/comms/mgetty+sendfax assumes presence of libutil
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Aug 29 20:40:00 UTC 2004
>Originator:     Georg Schwarz
>Release:        current pkgsrc
IRIX lorenz 5.3 08031225 IP20 mips
pkgsrc/comms/mgetty+sendfax´s Makefile is patched by patch-ab to contain LIBS=-lutil. However, this should only be valid for some platforms such as *BSD and maybe Linux. On IRIX 5.3 for example that library is neither present nor needed.
Another issue is that the user and group are hard-coded in Makefile. 
Moreover, Makefile is patched to use install (no absolute path), which might lead to using a non-BSD install (as it does on IRIX 5.3). Also, do not se
Additional note: on IRIX 5.3 at least I need gcc to compile mgetty+sendfax. The native cc does not like the C code.

Change the patch to comment out the LIBS= line instead and explicitely pass the correct LIBS for each platform, if needed. Also, do not set INSTALL, just use the definition passed by pkgsrc.