Subject: pkg/26662: lang/gawk should support pkg_views.
To: None <>
From: Ossi Herrala <>
List: pkgsrc-bugs
Date: 08/14/2004 18:38:18
>Number:         26662
>Category:       pkg
>Synopsis:       lang/gawk should support pkg_views.
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Sat Aug 14 15:40:00 UTC 2004
>Release:        NetBSD 2.0F
	LCFNet Internet Productions
System: NetBSD 2.0F NetBSD 2.0F (GENERIC) #0: Mon Jun 28 14:10:49 EEST 2004 i386
Architecture: i386
Machine: i386
	When using pkg_views software depending on lang/gawk can't
	be build if lang/gawk doesn't support pkg_views.
	Use pkg_views, try to build software which needs lang/gawk.
	Enable pkg_views for lang/gawk. See the following patch:

Index: Makefile
RCS file: /cvsroot/pkgsrc/lang/gawk/Makefile,v
retrieving revision 1.22
diff -u -r1.22 Makefile
--- Makefile	25 Apr 2004 07:15:51 -0000	1.22
+++ Makefile	14 Aug 2004 15:30:57 -0000
@@ -10,6 +10,8 @@
+PKG_INSTALLATION_TYPES= overwrite pkgviews
 CONFLICTS=	ja-gawk-[0-9]*

Ossi Herrala, OH8HUB
PGP: 0x78CD0337 / D343 F9C4 C739 DFFF F619  6170 8D28 8189 78CD 0337 

Hi! I am a .signature virus.  Copy me into your .signature to join in!