Subject: pkg/26612: possible bug with remind packages collection
To: None <>
From: None <>
List: pkgsrc-bugs
Date: 08/10/2004 17:22:28
>Number:         26612
>Category:       pkg
>Synopsis:       running `rem' or `remind ~/.reminders' produces remind in free(): warning: modified (chunk-) pointer.
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Aug 11 00:23:00 UTC 2004
>Originator:     xcitor
>Release:        NetBSD 1.6.2_STABLE
System: NetBSD sverige 1.6.2_STABLE NetBSD 1.6.2_STABLE (sdf) #0: Sun Jul 25 04:17:09 UTC 2004 root@ol:/var/src/src/sys/arch/alpha/compile/sdf alpha
Architecture: alpha
Machine: alpha
synopsis states it all. i've tried to debug to the best of my ability.
suspecting a malloc problem, i consulted the malloc(3) man page and saw:

     modified (chunk-/page-) pointer
             The pointer passed to free() or realloc() has been modified.

and i then i gave `MALLOC_OPTIONS' the value of `AJ' in my environment
to get remind to dump core on any malloc-related failure. i got a core
file, but it didnt' do me much good, as debugging symbols weren't

so i got a virgin copy of the remind sources (the same version in
the packages collection) and tried to build myself with debugging
symbols turned on. unfortunately, that version didn't dump core, so i'm
at a loss. and i've about exhausted my knowlege in this area.
run `rem' or `remind ~/.reminders', but i have no idea if this will
behave in such a way on any other system than this one, as i don't have
access to any other similar systems.
none known by me.