Subject: pkg/26361: pysol dependencies wrong
To: None <>
From: seebs <>
List: pkgsrc-bugs
Date: 07/19/2004 03:32:59
>Number:         26361
>Category:       pkg
>Synopsis:       pysol doesn't know that it needs pthreads?
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Jul 19 09:13:00 UTC 2004
>Originator:     seebs
>Release:        NetBSD 2.0G
System: NetBSD 2.0G NetBSD 2.0G (VASH) #0: Tue Jul 6 19:28:02 CDT 2004 i386
Architecture: i386
Machine: i386
	If no Python is installed when pysol is built from pkgsrc, the
	system seems to end up building the non-pthreads version of Python -
	and then is unable to load  I suspect that there's a
	missing hint indicating that the requirement is not just for some
	version of python, but for a pthreads version of python.
	Nuke all related packages, build pysol, and try to run it.
	Not sure.