Subject: pkg/26136: naim core dumps unexpectedly
To: None <>
From: None <>
List: pkgsrc-bugs
Date: 07/01/2004 17:12:03
>Number:         26136
>Category:       pkg
>Synopsis:       naim core dumps unexpectedly
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Jul 01 17:14:00 UTC 2004
>Release:        NetBSD 1.6.2
System: NetBSD nixsys 1.6.2 NetBSD 1.6.2 (NIXSYS) #10: Thu Mar 4 22:20:38 EST 2004 root@nixsys:/usr/src/sys/arch/alpha/compile/NIXSYS alpha
Architecture: alpha
Machine: alpha

The correspondance below is between myself and another user testing naim-0.11.7. This problem was assumingly non-existent with the prior version. I have been unable to duplicate it myself using aterm on NetBSD.

> >To:
> >Subject: Error msg for naim
> >
> >                                * [AIM (not connected)] naim
> >assertion "c->ectqar == NULL" failed: file "toc.c", line 976, function
> >"toc_destroy_handle"
> >           Abort (core dumped)
> >
> >
> >This is what that naim comes up with to the command called  /quit  and
> >/exit does the same thing
> >
> >
> >-AC
> >
> 1) What client are you using to connect via SSH: PuTTY? MindTerm? 
> Something else?
Mac ssh, the only change being that the colors were different

> 2) What value did you setenv TERM to: linux? something else?

yup to linux, the color scheme in term window was black background with 
green text..... and thats about all I can think of

> I could not reproduce this error when logging in and the exiting. This is 
> interesting and I will forward it as a PR once we have more info.
> Thanks for your help!
> !tr

Subject: errors des naim

Ok so I just tried it in putty with my standard procedure to logon and 
logoff procedure  and got the same error message.

1. setenv TERM linux
2. naim
3. /connect nosida
4. [enter pw]
5. /quit

error msg 976 

just tried it on PC with putty no color change just the above and got the 
error msg.


	make naim-0.11.7 in pkgsrc-current