Subject: pkg/26070: pkgsrc doesn't know about tools versions
To: None <>
From: None <>
List: pkgsrc-bugs
Date: 06/27/2004 00:45:37
>Number:         26070
>Category:       pkg
>Synopsis:       pkgsrc doesn't know about tools versions
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Sat Jun 26 14:46:00 UTC 2004
>Originator:     grant beattie
>Release:        pkgsrc-current
System: NetBSD mofo 2.0F NetBSD 2.0F (_mofo_) #8: Sat Jun 19 18:50:43 EST 2004 grant@mofo:/usr/src/sys/arch/i386/compile/_mofo_ i386
Architecture: i386
Machine: i386
the stuff does not know about tools versions. e.g. Firefox
needs GNU make 3.78 to build, but some (ancient) systems have and
earlier version of GNU make which does not satisfy the package's
code inspection.
make the tools stuff version-aware so packages/platforms can specify
minimum versions of (GNU) tools required.