Subject: pkg/25807: gpsd 1.07 does not compile ; gcc 3.3 requires stdard instead of varargs
To: None <>
From: None <>
List: pkgsrc-bugs
Date: 06/03/2004 20:17:24
>Number:         25807
>Category:       pkg
>Synopsis:       gpsd 1.07 needs change to build under gcc 3.3.x
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Jun 03 20:18:00 UTC 2004
>Release:        NetBSD 1.6ZL
cows of earth unite!
System: NetBSD 1.6ZL NetBSD 1.6ZL (X30) #1: Thu Jun 3 17:45:05 UTC 2004 i386
Architecture: i386
Machine: i386
gpsd 1.07 (found in /usr/pkgsrc/misc/gpsd) does not compile because one of its sources uses an include for varargs which is replaced by stdarg since gcc 3.3.x
building gpsd on current :)

--- netlib.c.orig	2004-06-03 19:40:38.000000000 +0000
+++ netlib.c	2004-06-03 19:41:16.000000000 +0000
@@ -9,7 +9,7 @@
 #include <sys/types.h>
 #include <sys/socket.h>
 #include <netinet/in.h>
-#include <varargs.h>
+#include <stdarg.h>
 #include <netdb.h>
 #include <stdio.h>
 #include <arpa/inet.h>