Subject: pkg/25745: Unable to compile Sablotron on NetBSD 1.5.2 (i386)
To: None <>
From: None <>
List: pkgsrc-bugs
Date: 05/29/2004 22:49:17
>Number:         25745
>Category:       pkg
>Synopsis:       Unable to compile Sablotron on NetBSD 1.5.2 (i386)
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          support
>Submitter-Id:   net
>Arrival-Date:   Sat May 29 22:50:00 UTC 2004
>Originator:     Franck MAHE
>Release:        1.5.2
Here is the result of the compilation of Sablotron.

[root@azrael sablotron]$ make update


checking whether to build the debugger... no
checking where to find xml parser... expat (new)
checking expat.h usability... no
checking expat.h presence... yes
configure: WARNING: expat.h: present but cannot be compiled
configure: WARNING: expat.h: check for missing prerequisite headers?
configure: WARNING: expat.h: proceeding with the preprocessor's result
configure: WARNING:     ## ------------------------------------ ##
configure: WARNING:     ## Report this to ##
configure: WARNING:     ## ------------------------------------ ##
checking for expat.h... yes
checking whether expat.h is broken... yes
configure: error: You probably have expat version 1.95.6. Please refer to:
  for a description of the problem.
*** Error code 1

*** Error code 1

*** Error code 1

[root@azrael sablotron]$

I tried the clue indicated by the link, but the result is the same... Unable to compile Sablotron.