Subject: pkg/25660: libtool scripts do not honor ${AWK}
To: None <>
From: None <>
List: pkgsrc-bugs
Date: 05/21/2004 22:26:57
>Number:         25660
>Category:       pkg
>Synopsis:       libtool scripts do not honor ${AWK}
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri May 21 22:27:00 UTC 2004
>Originator:     Georg Schwarz
>Release:        current pkgsrc
IRIX lorenz 5.3 08031225 IP20 mips
there are some sripts installed under ${LOCALBASE} (share/aclocal/libtool.m4, bin/libtool, bin/shlibtool) that simply call awk, thus not honoring the ${AWK} setting.
This can lead to problems on systems with no awk at all or a less capable version of awk (first) in the shell path.

replace awk by ${AWK} and maybe define AWK in the scripts to be installed, just as it is being done for SED now.