Subject: pkg/25612: ap-ssl pkg has circular dependency
To: None <>
From: None <>
List: pkgsrc-bugs
Date: 05/17/2004 13:59:19
>Number:         25612
>Category:       pkg
>Synopsis:       ap-ssl pkg has circular dependency
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon May 17 14:00:00 UTC 2004
>Originator:     Peter I. Hansen
>Release:        NetBSD 1.6
NetBSD 1.6 NetBSD 1.6 (GENERIC) #0: Sun Sep  8 19:43:40 UTC 2002 i386
If you install pkg /usr/pkgsrc/www/ap-ssl, this this requires apache and mod-ssl, but when /usr/pkgsrc/www/apache is installed, mod-ssl is included.

This seems to create a circular dependency i ap-ssl
cd /usr/pkgsrc/www/ap-ssl && make update
For me just installing apache and forgetting about ap-ssl seems to work.