Subject: pkg/25600: devel/boost, vesion 1.31.0 and libraries
To: None <>
From: None <>
List: pkgsrc-bugs
Date: 05/16/2004 20:05:21
>Number:         25600
>Category:       pkg
>Synopsis:       devel/boost, vesion 1.31.0 and libraries
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Sun May 16 20:06:00 UTC 2004
>Originator:     Ryoji Kato
>Release:        2.0_BETA
NetBSD vaio 2.0_BETA NetBSD 2.0_BETA (VAIO_NETBSD_20_CONF) #0: Thu May  6 10:02:42 JST 2004  ryoji@:/home/i386/src/sys/arch/i386/compile/VAIO_NETBSD_20_CONF i386

The current package of devel/boost installs the old version of
boost library (1.30.2) without any binary libraries (e.x.
boost.filesystem, boost.thread etc).

1. Install the current boost package.
2. Compile some programs that use boost thread libraries.
3. Then, you will get error messages from the compiler.