Subject: pkg/25436: p5-DBI conflicts with perl-5.8.4
To: None <>
From: None <>
List: pkgsrc-bugs
Date: 05/02/2004 20:19:28
>Number:         25436
>Category:       pkg
>Synopsis:       p5-DBI conflicts with perl-5.8.4
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun May 02 18:20:00 UTC 2004
>Originator:     Michael van Elst
>Release:        NetBSD 1.6.2_STABLE
                                Michael van Elst
                                "A potential Snark may lurk in every tree."
System: NetBSD pepew 1.6.2_STABLE NetBSD 1.6.2_STABLE (PEPEW) #5: Thu Apr 22 23:06:37 MEST 2004 src@pepew:/amd/fud/d/0/src/sys/arch/i386/compile/PEPEW i386
Architecture: i386
Machine: i386
Currently it is impossible to build p5-DBI with an installed perl-5.8.4.

This is caused by perl having Test::Simple (and Test::Harness) embedded
into the package. p5-DBI however requires the installation of p5-Test-Simple
(and p5-Test-Harness) which explicitely conflict with the perl package
since a few days.

Something similiar happens with p5-Net-DNS.

Build perl-5.8.4 and then p5-DBI.

p5-Test-Simple and p5-Test-Harness must not conflict with the perl
package but instead build to an empty dummy package if perl>=5.8.3
is installed.