Subject: pkg/25250: cksum mismatch for x11/xfce4-gtk2-engines
To: None <>
From: None <>
List: pkgsrc-bugs
Date: 04/20/2004 01:17:39
>Number:         25250
>Category:       pkg
>Synopsis:       cksum mismatch for x11/xfce4-gtk2-engines
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Apr 20 01:18:00 UTC 2004
>Originator:     George Peter Staplin
>Release:        2.0-beta (releng april 13 snapshot)
NetBSD magichimo 2.0_BETA NetBSD 2.0_BETA (GENERIC) #0: Sat Apr 17 07:29:06 UTC 2004 i386

The tarball cksum needed by the package doesn't match, even after a make distclean and remake.

Strangely the tarballs of 2.1.9 at the following locations seem to have the same mistmatched md5 sum:

# make
===> *** No /usr/pkgsrc/distfiles/pkg-vulnerabilities file found,
===> *** skipping vulnerability checks. To fix, install
===> *** the pkgsrc/security/audit-packages package and run
===> *** '/usr/pkg/sbin/download-vulnerability-list'.
=> gtk-xfce-engine-2.1.9.tar.gz doesn't seem to exist on this system.
=> Attempting to fetch gtk-xfce-engine-2.1.9.tar.gz from
=> [347548 bytes]
ftp: Error retrieving file - `404 Not Found'
=> Attempting to fetch gtk-xfce-engine-2.1.9.tar.gz from
=> [347548 bytes]
100% |***********************************************|   339 KB   23.97 KB/s    00:00 ETA
347525 bytes retrieved in 00:14 (23.97 KB/s)
=> Checksum mismatch for gtk-xfce-engine-2.1.9.tar.gz.
Make sure the Makefile and checksum file (/usr/pkgsrc/x11/xfce4-gtk2-engines/distinfo)
are up to date.  If you want to override this check, type

Update the sum or ignore it -- if you trust that the file hasn't become corrupt or turned into a trojan.  The official XFCE SourceForge site doesn't even have 2.1.9  They only seem to have 2.1.1 at SourceForge.

Thanks for making pkgsrc so good :)