Subject: pkg/25117: mail/sylpheed doesn't compile
To: None <>
From: None <>
List: pkgsrc-bugs
Date: 04/09/2004 17:47:56
>Number:         25117
>Category:       pkg
>Synopsis:       mail/sylpheed doesn't compile
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Apr 09 17:48:01 UTC 2004
>Originator:     Soeren Bleikertz
>Release:        2.0C
NetBSD berry 2.0C NetBSD 2.0C (BERRY) #10: Thu Apr  8 20:21:24 CEST 2004  soeren@berry:/usr/obj/sys/arch/i386/compile/BERRY i386
mail/sylpheed fails when checking glib-version, because ./conftest segfault.

checking for GLIB - version >= 1.2.6... no
*** Could not run GLIB test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding GLIB or finding the wrong
*** version of GLIB. If it is not finding GLIB, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ to point
*** to the installed location  Also, make sure you have run ldconfig if that
*** is required on your system
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
*** If you have a RedHat 5.0 system, you should remove the GTK package that
*** came with the system with the command
***    rpm --erase --nodeps gtk gtk-devel
configure: error: Test for GLIB failed. See the file 'INSTALL' for help.
*** Error code 1

and the config.log entry:

configure:25665: checking for GLIB - version >= 1.2.6
configure:25769: gcc -o conftest -O2 -I/usr/pkg/include -I/usr/include -I/usr/pk
g/include/freetype2 -I/usr/pkg/include/glib/glib-1.2 -I/usr/pkg/lib/glib/include
 -D_REENTRANT -I/usr/pkg/include -I/usr/include -I/usr/pkg/include/freetype2 -L/
usr/pkg/lib -Wl,-R/usr/pkg/lib -L/usr/lib -Wl,-R/usr/lib -L/usr/pkg/X11R6/lib -W
l,-R/usr/pkg/X11R6/lib conftest.c -L/usr/pkg/lib -Wl,-R/usr/pkg/lib -lgthread -l
glib -lpthread -lintl >&5     
ld: warning:, needed by /usr/pkgsrc/mail/sylpheed/work/.buildlin
k/lib/, may conflict with
configure:25772: $? = 0
configure:25774: ./conftest
[1]   Segmentation fault (core dumped) ./conftest${ac_e...
configure:25777: $? = 139     
configure: program exited with status 139

try make in mail/sylpheed