Subject: pkg/25074: gnome2-games missing librsvg2-gtk2 dependency
To: None <>
From: None <>
List: pkgsrc-bugs
Date: 04/06/2004 18:30:36
>Number:         25074
>Category:       pkg
>Synopsis:       gnome2-games missing librsvg2-gtk2 dependency
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Apr 06 15:37:00 UTC 2004
>Originator:     Arto Huusko
>Release:        NetBSD 1.6ZF
System: NetBSD 1.6ZF NetBSD 1.6ZF (MAAILMA) #2: Mon Dec 1 21:44:24 EET 2003 arto@lady:/data/netbsd/current/alpha/obj/sys/arch/alpha/compile/MAAILMA alpha
Architecture: alpha
Machine: alpha
	gnome2-games does not depend on librsvg2-gtk2.

	librsvg2-gtk2 provides the SVG loader for gdk-pixbuf. At least
	gnomine in gnome2-games tries to load SVG graphics using gdk-pixbuf.
	If librsvg2-gtk2 is not installed, gnomine does not work.
	Remove librsvg2-gtk2 from the system, build gnome2-games and observe
	that gnomine does not work.
	Make gnome2-games depend on librsvg2-gtk2.