Subject: pkg/25047: audio/libsndfile depends on gcc3
To: None <>
From: None <>
List: pkgsrc-bugs
Date: 04/04/2004 08:52:18
>Number:         25047
>Category:       pkg
>Synopsis:       audio/libsndfile depends on gcc3
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Apr 04 06:53:00 UTC 2004
>Originator:     Michael van Elst
>Release:        NetBSD 1.6.2
                                Michael van Elst
                                "A potential Snark may lurk in every tree."
System: NetBSD pepew 1.6.2 NetBSD 1.6.2 (PEPEW) #1: Mon Feb 23 23:34:11 MET 2004 src@pepew:/amd/fud/d/0/src/sys/arch/i386/compile/PEPEW i386
Architecture: i386
Machine: i386
The current audio/libsndfile package cannot be build on a stock NetBSD
system. Configure bails out with:

checking for ANSI C header files... (cached) yes
checking endian.h usability... no
checking endian.h presence... no
checking for endian.h... no
checking for sys/wait.h that is POSIX.1 compatible... yes
checking whether S_IRGRP is declared... yes
checking struct hack support... no
configure: error:
        *** This compiler does not support the 1999 ISO C Standard ***
        *** feature known as the "struct hack".                    ***
        *** Try GNU GCC-3.1 or later as they are known to work.    ***

Try to build audio/libsndfile on NetBSD-1.6.2 without using gcc3

none known