Subject: Re: can get NetBSD 4.0_RC5 to work with 2 nics
To: None <>
From: Dennis den Brok <>
List: netbsd-users
Date: 12/15/2007 00:14:28
(I think is a better place to ask.)

There are various PCI_*_FIXUP options in GENERIC.NOACPI, commented
out. You could try building a kernel with some of them enabled.
There's also PCIBIOS to check out. Apart from that, I can't help,
I'm afraid. Good luck anyways.


-- Dennis den Brok

	From dennis Fri Dec 14 21:20:25 2007
	X-Brightmail-Tracker: AAAAAA==
	X-BrightmailFiltered: true
	X-IronPort-AV: E=Sophos;i="4.24,169,1196636400"; 
	DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=gamma;
	DomainKey-Signature: a=rsa-sha1; c=nofws;; s=gamma;
	Date: Fri, 14 Dec 2007 14:16:37 -0600
	From: "Rick McCombs" <>
	To: "Dennis den Brok" <>
	Subject: Re: can get NetBSD 4.0_RC5 to work with 2 nics
	In-Reply-To: <slrnflffr1.n28.d.den.brok@ikosaegor.lokales.netz>
	MIME-Version: 1.0
	Content-Type: text/plain; charset=ISO-8859-1
	Content-Transfer-Encoding: 7bit
	Content-Disposition: inline
	References: <>

	On Dec 6, 2007 3:22 AM, Dennis den Brok <> wrote:
	> Rick McCombs <> schrieb:
	> > Well I decided to try NetBSD 4.0 RC_5  and for some reason is could
	> > not map io memory for my NIC which has the markings MUN-JIN FT16-04B2
	> > and works with the rtk driver in NetBSD 3.1  I don't remember where I
	> > got the card.
	> >
	> > Also I have a Netgear  nic that uses the sip driver that works in 3.1
	> > but with RC_5 I got can't map registers.
	> > I don't remember the Netgear model and I don't have time to open the
	> > machine back up  right now.
	> > I put 3.1 back on and I'm trying to get back to the point I was before.
	> >
	> Did you try GENERIC.NOACPI? AFAIR, 3.1 GENERIC had ACPI disabled,
	> while 4.0 has it enabled by default. Maybe ACPI messes it up?

	I tried NOACPI with the K6-2 and my nic works but usb doesn't

	ohci0 at pci0 dev 1 function 2: Silicon Integrated System 5597/5598
	USB host controller (rev. 0x11)
	ohci0: can't map mem space

	I don't use USB much on that one so I might live with it.
	I also have a Pentium II that the USB doesn't work with Netbsd 4.0 RC5
	but there is nothing in the dmesg about it at all like it doesn't
	recognize it as even being there I tried GENERIC and NOACPI  If I copy
	more than one kernel to the harddrive  can I chose a different one
	whne I boot?  I tried something like that and it ran the install menu.
	 I don't remember  if the Pentium II's USB worked in 3.1.

	Email  If you want a gmail invitation just ask.
	Amateur Radio AD5DU.
	home page