Subject: Re: auich doesn't work properly in 4.0_RC2
To: Cliff Wright <>
From: Alexey Lebedev <>
List: netbsd-users
Date: 10/15/2007 11:34:51
On Fri, 12 Oct 2007 10:57:21 -0700
Cliff Wright <> wrote:

> I sent an email out April 27 2007 on this.
> I had a hack that only partially worked.
> You will notice from your listing the line:
> LNKB: BIOS IRQ 10 for 0.31.INTB is invalid.
> I believe this your audio. What I found for me was
> that the ACPI tables showed only interrupt 5, and 7 as possible interrupts, and thus the error message.
> However bios did assign an interrupt, and indeed if not using an APIC, only bios not the O/S will
> assign the interrupt, so what it assigns must be
> used.
> I removed the call to the subroutine that checked
> if the bios assigned interrupt was in the ACPI
> supplied list, then the audio worked. However
> I am getting some distortion in the sound. It
> sounds to me like their might still be an interrupt
> problem. Look at:
> for the patch I used.
> -- 
> Cliff Wright <>

Actually I don't realy understand the details. But your patch works.
And besides, there is no distortion. Thank you very much.
Is this patch "quick and dirty"? I mean why not to add it to 4.0?

Alexey Lebedev <>