Subject: Re: RC1 problem Re: a very slow 2.2Ghz amd64
To: None <>
From: George Georgalis <>
List: netbsd-users
Date: 10/08/2007 13:37:13
On Fri, Oct 05, 2007 at 11:41:43AM -0400, George Georgalis wrote:
>On Fri, Oct 05, 2007 at 10:38:25AM -0400, George Georgalis wrote:
>>On Thu, Oct 04, 2007 at 07:33:10PM -0000, De Zeurkous wrote:
>>>On Thu, October 4, 2007 18:56, George Georgalis wrote:
>>>> viaide0 at pci0 dev 6 function 0
>>>> viaide0: NVIDIA nForce4 IDE Controller (rev. 0xf2)
>>>Your very problem, right there. The nForce ATA controllers are complete
>>>crap. Known issue, go bug 'NVIDIA' about it...
>>well the thing is, I have an identical box in production with
>>netbsd-3 and it doesn't have a problem compared to this RC1 box.
>>I looked in BIOS but didn't see any "sata emulate pata" options.
>>maybe the bios is different on this box.  I'm going to try
>>rebuilding this host with -3 and see if I get any improvement.
>Absolutely! This box runs 20 times faster with 3.1
>NetBSD rock 3.1 NetBSD 3.1 (GENERIC) #0: Mon Oct 30 21:47:28 UTC 2006 amd64
>I presume it's a nForce4 IDE issue, but in any event the syncer
>seems to remain busy and sys cpu utilization remains high (almost
>exclusive) with 4_RC1.
>Can anyone give me more specific clues (file) to blame on a PR?

This is resolved in 4_RC2. no apparent slowdown.

FWIW - Another item I noticed is this high sys cpu
utilization state was consuming a lot of semaphores
too. ...I really like seeing the "Dynamic limits
for SysV semaphores and message queues" thread on
tech-kern. adding semaphores has been the primary
reason I've needed to recompile kernels!

// George

George Georgalis, information system scientist <IXOYE><