Subject: Re: nsswitch and libnss_winbind
To: Luke Mewburn <>
From: Sarton O'Brien <>
List: netbsd-users
Date: 05/30/2007 15:13:53
On Wed, 30 May 2007 02:39:27 pm Luke Mewburn wrote:
> On NetBSD, you can use the getent(1) command to perform lookups
> in the various databases that are switched through nsswitch.conf.
> This should help in testing your nsswitch.conf and /lib/
> setup.
> For example, does 'getent passwd' dump your entire /etc/passwd and
> winbind maps if you're using ``passwd: files winbind'' ?

I mentioned in the first email that I was using 'getent group' for testing. 
This unfortunately yields no results other than that of the system group 

Using jabberd2 with pam auth shows that pam_winbind is working, it's just not 
submitting the username correctly but that's another issue.

Using nss_ldap on the same system and testing with getent works flawlessly.

Even if there was a failure to utilise libnss_winbind properly, it would be 
reported within winbindd debug. At this point I'm not seeing anything, as if 
the library is not where it is suppose to be.

And like I said, I've tried copying, linking and renaming in multiple 
locations to no avail.

This problem isn't mission critical, it's more like an option I tried and 
moved on from but never-the-less, I could see potential for other things I am 
needing to consolidate at a later date.

Thanks again,