Subject: Pthread issues in NetBSD 4.0 (was Java for NetBSD)
To: Bill Stouder-Studenmund <>
From: Jean-Luc Wasmer <>
List: netbsd-users
Date: 05/29/2007 22:27:08
Bill Stouder-Studenmund wrote:
> Recently (past few years), Sun has been more open about licensing a NetBSD 
> Java. Unfortunately there are issues in libpthread in NetBSD 4.0 that 
> prevent it from working. I think -current stands a much better chance, and 
> I also hope to address some of the concurrency issues on the 
> wrstuden-fixsa branch (which is a netbsd-4 branch).
What are these issues?

OpenLDAP is not working for me on 4.0 beta2 (pthread issues). So far 
I've assumed it was a misuse of the pthread API (PR: pkg/36407).