Subject: Re: apache 1.3 crashing when I enable PERL?
To: Gilles Gravier <>
From: Wouter Schoot <>
List: netbsd-users
Date: 04/21/2007 14:36:43
Gilles Gravier schreef:
> PERL 5 is already built on my system... so I go to ap-perl and make
> install...

> LoadModule perl_module lib/httpd/
> <Files ~ "\.pl$">
>   PerlHandler         Apache::Registry
>   PerlSendHeader      On
>   SetHandler          perl-script
>   Options             +ExecCGI
> </Files>

> bash-3.2# /etc/rc.d/apache start
> [1]   Abort trap (core dumped) ${HTTPD} -DSSL
> /usr/pkg/sbin/apachectl startssl: httpd could not be started
> bash-3.2#


This is exactly what I encountered a few weeks back which costs me a night
of trouble. I orgininally suspected it to be my flacky config (NetBSD 2
userland, NetBSD 4_BETA2 kernel (for my raid chipset support)), and PHP
with apache 1.3 is no problem, but when I added perl support, fun was all
over. However, recompiling didn't fix it. Even worse, apache 2 didn't
solve it either! But, good news, apache 2.2 (also in pkgsrc) solves this

I realise this is just a workaround and, considering I'm not the only one
anymore, it would be good to send-pr this problem I suppose!


Wouter Schoot (
UIN# 42109851